Beam Platform - Third-party cloud services provider affecting some of our services – Incident details

Third-party cloud services provider affecting some of our services

Resolved
Operational
Started about 1 year agoLasted about 1 hour

Affected

Beam's Application Portal

Operational from 8:38 PM to 10:06 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Update

    We are continuing to monitor for any further issues.

  • Monitoring
    Update

    We are continuing to monitor for any further issues.

  • Monitoring
    Monitoring

    We are currently experiencing partially degraded service due to an outage with our third-party cloud services provider. Affected functionality includes document upload and payment services; we recommend users avoid managing documents or initiating payments as these actions will not be successful. All other features and functionality are operating normally. We will continue to monitor the third-party outage and provide updates as they become available.