Beam Platform - Widespread Cloud Provider Outage Impacting Platform Availability – Incident details

Widespread Cloud Provider Outage Impacting Platform Availability

Resolved
Degraded performance
Started 19 days agoLasted about 3 hours

Affected

Beam's Partner Portal

Operational from 6:31 PM to 8:24 PM, Major outage from 8:24 PM to 9:35 PM

Beam's Applicant Portal

Operational from 6:31 PM to 8:24 PM, Major outage from 8:24 PM to 9:35 PM

Payment System

Operational from 6:31 PM to 8:24 PM, Major outage from 8:24 PM to 9:35 PM

Updates
  • Resolved
    Resolved
    Service has stabilized and all systems are operating normally again. It appears the broader internet disruption has been resolved. We’ll continue to monitor for any lingering effects, but everything looks good at this time.
  • Monitoring
    Monitoring

    We're seeing signs of recovery as the underlying cloud provider issues begin to resolve. Our platform is no longer experiencing a full outage, but some functionality may remain slow or intermittently available. We're continuing to monitor closely and will provide further updates as service stabilizes.

  • Investigating
    Investigating
    We are currently experiencing degraded performance and partial outages across our platform due to a widespread issue affecting major cloud providers. Our team is actively monitoring the situation and working to mitigate the impact. Updates will follow as we learn more.