Beam Platform - Partial Payment System Issues – Incident details

Partial Payment System Issues

Resolved
Partial outage
Started 28 days agoLasted about 5 hours

Affected

Payment System

Partial outage from 1:13 PM to 6:39 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. The fix from our banking partner was successful, and Beam payments services are fully operational now.

  • Monitoring
    Monitoring

    Our banking parter has identified the issue, and we are implementing a fix now. We'll provide another update shortly.

  • Identified
    Update

    We have identified the cause of payment failures to be an issue in the systems of our banking partner, who is actively working to resolve it. The issue affects multiple banking customers on their end, but we are attempting to prioritize Beam payments so we can return our services to normal as soon as possible.

  • Identified
    Identified

    We have partially identified the problem, and we continue to investigate issues with one of our payments vendors. Partners and users may experience issues with payment related transactions.

  • Investigating
    Investigating

    We are having issues with an aspect of our payments system and are reaching out to our vendor to investigate.